aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-12-08 02:32:09 -0800
committerChris Robinson <[email protected]>2010-12-08 02:32:09 -0800
commit0218957eb5c22fd5a514545149ccb2275a3ed0d5 (patch)
treeddb660b47ae6261b938e477968ce4c36ba03a43f /CMakeLists.txt
parentcd65ab7dfaa07e3fb773de88fca7710393777568 (diff)
Use "internal" visibility by default
All functions callable by apps, directly or indirectly (eg, through function pointers), are marked as "protected", and internal visibility can provide benefits over hidden when we know functions won't be called by other modules.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0842aae7..1aa568f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,7 +133,7 @@ ELSE()
CHECK_C_SOURCE_COMPILES("int foo() __attribute__((visibility(\"default\")));
int main() {return 0;}" HAVE_GCC_VISIBILITY)
IF(HAVE_GCC_VISIBILITY)
- ADD_DEFINITIONS(-fvisibility=hidden -DHAVE_GCC_VISIBILITY)
+ ADD_DEFINITIONS(-fvisibility=internal -DHAVE_GCC_VISIBILITY)
ENDIF()
ENDIF()
ENDIF()