aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorilya-fedin <[email protected]>2022-05-14 02:39:43 +0400
committerGitHub <[email protected]>2022-05-13 15:39:43 -0700
commit0bf2abae9b2121c3bc5a56dab30eca308136bc29 (patch)
tree2c28148c10eb626867781b9ddc939b3b10f7090e /CMakeLists.txt
parente0d26ba25ab84f5a04a6ad2ef497cd0e93684a40 (diff)
Fix pkg-config file when libdir/bindir/includedir specified as absolute paths (#696)
Currently it makes the pkg-config file unusable as prefix is specified twice. FULL variables do the necessary parsing and automatically prepend the prefix if needed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebfcc4e6..b1c7ede0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1261,9 +1261,9 @@ endif()
# Needed for openal.pc.in
set(prefix ${CMAKE_INSTALL_PREFIX})
set(exec_prefix "\${prefix}")
-set(libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}")
-set(bindir "\${exec_prefix}/${CMAKE_INSTALL_BINDIR}")
-set(includedir "\${prefix}/${CMAKE_INSTALL_INCLUDEDIR}")
+set(libdir "${CMAKE_INSTALL_FULL_LIBDIR}")
+set(bindir "${CMAKE_INSTALL_FULL_BINDIR}")
+set(includedir "${CMAKE_INSTALL_FULL_INCLUDEDIR}")
set(PACKAGE_VERSION "${LIB_VERSION}")
set(PKG_CONFIG_CFLAGS )
set(PKG_CONFIG_PRIVATE_LIBS )