aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2022-04-27 01:25:15 -0700
committerChris Robinson <[email protected]>2022-04-27 01:25:15 -0700
commit22e6c0df6017aa86e2cd83d8073e4d490c55dd11 (patch)
tree3065d22349d64aba8591de10266da22bc3903a6d /CMakeLists.txt
parent514ff1d71bfe0fce30d7e7379121d058c2506c25 (diff)
Check for a minimum PipeWire version
The backend is apparently using some stuff that wasn't in earlier headers, but it's not clear what was introduced in which versions. 0.3.23 should work, though it may need to be higher or it could go a bit lower.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d52754c9..ea646617 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -912,7 +912,7 @@ endif()
# Check PipeWire backend
option(ALSOFT_REQUIRE_PIPEWIRE "Require PipeWire backend" OFF)
if(PkgConfig_FOUND)
- pkg_check_modules(PIPEWIRE libpipewire-0.3)
+ pkg_check_modules(PIPEWIRE libpipewire-0.3>=0.3.23)
if(PIPEWIRE_FOUND)
option(ALSOFT_BACKEND_PIPEWIRE "Enable PipeWire backend" ON)
if(ALSOFT_BACKEND_PIPEWIRE)