aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2022-02-14 14:22:45 -0800
committerChris Robinson <[email protected]>2022-02-14 14:22:45 -0800
commit246412bfa6c7aa7329a3115afd26aff7709142b8 (patch)
tree34457d961ae8cafda13b04271bd3b8542f110bd0 /CMakeLists.txt
parent2212b8d8ade3816d954d920a3e117d36931bcf3a (diff)
Rename deprecated -> legacy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e086039..ac50c0ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,7 +95,7 @@ option(ALSOFT_INSTALL_EXAMPLES "Install example programs (alplay, alstream, ...)
option(ALSOFT_INSTALL_UTILS "Install utility programs (openal-info, alsoft-config, ...)" ON)
option(ALSOFT_UPDATE_BUILD_VERSION "Update git build version info" ON)
-option(ALSOFT_EAX "Enable EAX extensions." ${WIN32})
+option(ALSOFT_EAX "Enable legacy EAX extensions" ${WIN32})
if(DEFINED SHARE_INSTALL_DIR)
message(WARNING "SHARE_INSTALL_DIR is deprecated. Use the variables provided by the GNUInstallDirs module instead")
@@ -1485,7 +1485,7 @@ if(FPMATH_SET)
endif()
if(ALSOFT_EAX)
- message(STATUS "Building with deprecated EAX extensions
+ message(STATUS "Building with legacy EAX extensions
")
endif()
@@ -1494,11 +1494,6 @@ if(ALSOFT_EMBED_HRTF_DATA)
")
endif()
-if(ALSOFT_EAX)
- message(STATUS "Enabled deprecated EAX extensions
-")
-endif()
-
# Install main library
if(ALSOFT_INSTALL)
configure_package_config_file(OpenALConfig.cmake.in OpenALConfig.cmake