aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2021-11-08 21:16:33 -0800
committerChris Robinson <[email protected]>2021-11-08 21:16:33 -0800
commit35348869a9deb989328ed206c70c14ac3418c2ef (patch)
treed1d2f55c705cd417742d5d6a467cdd61304763dd /CMakeLists.txt
parente3168c91124736cad96db902441274dd9e9aa374 (diff)
Disable MSVC warning 4127
"conditional expression is constant", which C++14 can't do anything about since 'if constexpr' was added in C++17. The checks are necessary since it's dealing with a templatized type, or a compile-time non-macro constant for the target system's endian order.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ed212db..77b765c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,7 +215,7 @@ if(MSVC)
if(HAVE_PERMISSIVE_SWITCH)
set(C_FLAGS ${C_FLAGS} $<$<COMPILE_LANGUAGE:CXX>:/permissive->)
endif()
- set(C_FLAGS ${C_FLAGS} /W4 /w14640 /wd4065 /wd4268 /wd4324 /wd5030)
+ set(C_FLAGS ${C_FLAGS} /W4 /w14640 /wd4065 /wd4127 /wd4268 /wd4324 /wd5030)
# Remove /W3, which is added by default, since we set /W4. Some build
# generators with MSVC complain about both /W3 and /W4 being specified.
foreach(flag_var CMAKE_C_FLAGS CMAKE_CXX_FLAGS)