aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2016-12-21 21:56:51 -0800
committerChris Robinson <[email protected]>2016-12-21 21:56:51 -0800
commit40f359d1592263245da409c790c2a48b98a1e815 (patch)
treeb9516c140b3b355eb1221019e173ad52d3e87446 /CMakeLists.txt
parent080b0cea8ba4c21f898c18b70187822cd18f2eb6 (diff)
Rename the version target for systems that have a version lib
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55c832ad..839bf183 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1177,7 +1177,7 @@ ENDIF()
FIND_PACKAGE(Git)
IF(GIT_FOUND AND EXISTS "${OpenAL_SOURCE_DIR}/.git")
# Get the current working branch and its latest abbreviated commit hash
- ADD_CUSTOM_TARGET(version
+ ADD_CUSTOM_TARGET(build_version
${CMAKE_COMMAND} -D GIT_EXECUTABLE=${GIT_EXECUTABLE}
-D LIB_VERSION=${LIB_VERSION}
-D SRC=${OpenAL_SOURCE_DIR}/version.h.in
@@ -1294,8 +1294,8 @@ IF(WIN32 AND NOT LIBTYPE STREQUAL "STATIC")
ENDIF()
TARGET_LINK_LIBRARIES(${LIBNAME} common ${EXTRA_LIBS})
-IF(TARGET version)
- ADD_DEPENDENCIES(${LIBNAME} version)
+IF(TARGET build_version)
+ ADD_DEPENDENCIES(${LIBNAME} build_version)
ENDIF()
IF(ALSOFT_INSTALL)