aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-04-09 20:48:01 -0700
committerChris Robinson <[email protected]>2019-04-09 20:48:01 -0700
commit460a01443c925013f3f9dadeab5d07373ac5c894 (patch)
tree10d4f7bbe3eeec95f462403574a335b9e9b05495 /CMakeLists.txt
parente6daab51e8cd06c66680eb88e4b83ca3fb5918b0 (diff)
Add macros to stop exceptions from leaving API functions
Effectively makes the functions act as noexcept, since there's no meaningful reason to propogate exceptions from "C" functions. Currently only applied to ALC functions, but can incrementally be applied to AL functions too. In the future, this could also handle ALC and AL errors with unique exception types (functions that utilize this behavior would need to ensure proper cleanup).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5884a0f..411ae1ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -642,6 +642,7 @@ ENDIF()
SET(COMMON_OBJS
common/alcomplex.cpp
common/alcomplex.h
+ common/alexcpt.h
common/almalloc.cpp
common/almalloc.h
common/alnumeric.h