aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2014-05-07 19:16:49 -0700
committerChris Robinson <[email protected]>2014-05-07 19:16:49 -0700
commita2bddb7b40960b3a8680afa0ab31e99d204dece1 (patch)
tree999977561aff4cec16ee966c494666371a60fde7 /CMakeLists.txt
parent3e274c3a5784daa313fb5f7663f1b1fc55f5cefc (diff)
Move RWLock and UIntMap implementations to common
This should make the code in common completely self-reliant.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6e0761e..aae35f5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -499,7 +499,9 @@ ENDIF()
SET(COMMON_OBJS common/atomic.c
+ common/rwlock.c
common/threads.c
+ common/uintmap.c
)
SET(OPENAL_OBJS OpenAL32/alAuxEffectSlot.c
OpenAL32/alBuffer.c