aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2016-04-23 17:29:51 -0700
committerChris Robinson <[email protected]>2016-04-23 17:29:51 -0700
commitc2dec5008b02a3d85669036a4096430ce91275f9 (patch)
tree57ba26168a312cdd3c45cd45c85060de4d46c260 /CMakeLists.txt
parentc6a11770c591fb65f1dfad0c8775efac500b3413 (diff)
Install the ambdec preset files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c89a0d5..b713e261 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,7 @@ OPTION(ALSOFT_TESTS "Build and install test programs" ON)
OPTION(ALSOFT_CONFIG "Install alsoft.conf sample configuration file" ON)
OPTION(ALSOFT_HRTF_DEFS "Install HRTF definition files" ON)
+OPTION(ALSOFT_AMBDEC_PRESETS "Install AmbDec preset files" ON)
OPTION(ALSOFT_INSTALL "Install headers and libraries" ON)
@@ -1227,6 +1228,19 @@ IF(ALSOFT_HRTF_DEFS)
MESSAGE(STATUS "")
ENDIF()
+# Install AmbDec presets
+IF(ALSOFT_AMBDEC_PRESETS)
+ INSTALL(FILES presets/3D7.1.ambdec
+ presets/hexagon.ambdec
+ presets/rectangle.ambdec
+ presets/square.ambdec
+ presets/presets.txt
+ DESTINATION ${SHARE_INSTALL_DIR}/openal/presets
+ )
+ MESSAGE(STATUS "Installing HRTF definitions")
+ MESSAGE(STATUS "")
+ENDIF()
+
IF(ALSOFT_UTILS)
ADD_EXECUTABLE(openal-info utils/openal-info.c)
TARGET_LINK_LIBRARIES(openal-info ${LIBNAME})