aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2022-02-22 08:25:40 -0800
committerChris Robinson <[email protected]>2022-02-22 08:25:40 -0800
commitd22699d9bd098a2800b8434a22d9e59209065de2 (patch)
treefe91523894832a11688b62d58250648992a4365c /CMakeLists.txt
parentd3d9f8ca3df46aa2c74cb3eb4f598564e107a0d7 (diff)
Add a OpenAL::OpenAL cmake target alias
For when built as a sub-project, to clarify it's a target instead of a library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e926c1e7..c9681de4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1494,6 +1494,9 @@ if(ALSOFT_EMBED_HRTF_DATA)
message(STATUS "")
endif()
+# An alias for sub-project builds
+add_library(OpenAL::OpenAL ALIAS OpenAL)
+
# Install main library
if(ALSOFT_INSTALL)
configure_package_config_file(OpenALConfig.cmake.in OpenALConfig.cmake