aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-01-11 09:32:22 -0800
committerChris Robinson <[email protected]>2008-01-11 09:32:22 -0800
commitf10408739e22cea6b3c52b8a9f6e36792c33d855 (patch)
tree547df88fe3dcbbbd51c72c56067e5cf173b3f9ae /CMakeLists.txt
parente1d0ad749bd5772d968aa8b5ed600dee905310a4 (diff)
Add a wave file writing backend
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4955d250..ee2cc94e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,6 +190,7 @@ SET(ALC_OBJS Alc/ALc.c
Alc/alcRing.c
Alc/alcThread.c
Alc/bs2b.c
+ Alc/wave.c
)
SET(BACKENDS "")
@@ -263,6 +264,9 @@ IF("${HAVE_WINDOWS_H}")
ENDIF()
ENDIF()
+# This is always available
+SET(BACKENDS ${BACKENDS} WaveFile)
+
# End configuration
CONFIGURE_FILE(
"${OpenAL_SOURCE_DIR}/config.h.in"