aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2020-03-22 08:05:22 -0700
committerChris Robinson <[email protected]>2020-03-22 08:05:22 -0700
commitf6a0b004e0424e1f12a226b3b3c7193063eb02e3 (patch)
treeedd3cd8bd49a1ff2d0b6f58bceaa79c66c2e9de2 /CMakeLists.txt
parentadf28d87aac0be1f21a38e5c5e720cae281989ce (diff)
Update to C++14
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 592a7687..2a8d6a97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,8 +125,8 @@ SET(EXPORT_DECL "")
CHECK_TYPE_SIZE("long" SIZEOF_LONG)
-# Require C++11
-SET(CMAKE_CXX_STANDARD 11)
+# Require C++14
+SET(CMAKE_CXX_STANDARD 14)
SET(CMAKE_CXX_STANDARD_REQUIRED TRUE)
# Prefer C11, but support C99 and C90 too.