aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-02-05 12:07:51 -0800
committerChris Robinson <[email protected]>2010-02-05 12:07:51 -0800
commit54dc26b1454de33859e912e757bfa97f9a2e6fd0 (patch)
tree2855776aa3ca8038579df9fdfccbc8e9cf3d5e41 /CMakeLists.txt
parent78c1629aebdda5281f9a4f9836d2a1812321c18c (diff)
Enable the WinMM backend only if the lib check succeeds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f76d7259..e30f4ff1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -365,15 +365,15 @@ IF(HAVE_WINDOWS_H)
IF(WINMM)
CHECK_INCLUDE_FILES("windows.h;mmsystem.h" HAVE_MMSYSTEM_H -D_WIN32_WINNT=0x0500)
IF(HAVE_MMSYSTEM_H)
- SET(HAVE_WINMM 1)
- SET(ALC_OBJS ${ALC_OBJS} Alc/winmm.c)
- SET(BACKENDS "${BACKENDS} WinMM,")
-
SET(CMAKE_REQUIRED_LIBRARIES winmm)
CHECK_C_SOURCE_COMPILES("int main() {return 0;}" HAVE_LIBWINMM)
SET(CMAKE_REQUIRED_LIBRARIES "")
# CHECK_LIBRARY_EXISTS(winmm waveInOpen "" HAVE_LIBWINMM)
IF(HAVE_LIBWINMM)
+ SET(HAVE_WINMM 1)
+ SET(ALC_OBJS ${ALC_OBJS} Alc/winmm.c)
+ SET(BACKENDS "${BACKENDS} WinMM,")
+
SET(EXTRA_LIBS winmm ${EXTRA_LIBS})
ENDIF()
ENDIF()