aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-07-22 11:26:56 -0700
committerChris Robinson <[email protected]>2008-07-22 11:26:56 -0700
commit646714b5858056470c328413e2c99efac9a046f5 (patch)
treef3767ccd20dd91e896dd11912f413fbb5f30a793 /CMakeLists.txt
parenteba60c30c5e1676786b33be38c3845d850e96bcb (diff)
Set the new linking policy for CMake 2.6 to avoid warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 511405ef..7a43b250 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,11 @@
# CMake build file list for OpenAL
+CMAKE_MINIMUM_REQUIRED(VERSION 2.4)
+
+IF(COMMAND CMAKE_POLICY)
+ CMAKE_POLICY(SET CMP0003 NEW)
+ENDIF(COMMAND CMAKE_POLICY)
+
INCLUDE(CheckFunctionExists)
INCLUDE(CheckLibraryExists)
INCLUDE(CheckIncludeFile)