aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-09-16 01:44:45 -0700
committerChris Robinson <[email protected]>2012-09-16 01:44:45 -0700
commita1daec66e29cf90132d4a5e51e00b04a162f15be (patch)
tree8f6dc98a0e1100d7bdd18fc7c663c251b418f143 /CMakeLists.txt
parent657ee85136861c9da105a67050ae84a85ecfe808 (diff)
Use __control87_2 when available
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 64656c45..88e2a38c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -277,6 +277,7 @@ IF(HAVE_FENV_H)
ENDIF()
IF(HAVE_FLOAT_H)
CHECK_SYMBOL_EXISTS(_controlfp float.h HAVE__CONTROLFP)
+ CHECK_SYMBOL_EXISTS(__control87_2 float.h HAVE___CONTROL87_2)
ENDIF()
CHECK_FUNCTION_EXISTS(strtof HAVE_STRTOF)