aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-12-02 02:37:51 -0800
committerChris Robinson <[email protected]>2008-12-02 02:37:51 -0800
commita71c291bcbd63af8a50af0e37f57e2ef1c57b4cd (patch)
treeedf0eec52e910360db7049f8371c819bde562124 /CMakeLists.txt
parent55b9ccc2deacf6870cabff704239caf2c85493fa (diff)
Let CMAKE_DEBUG_POSTFIX be exposed for graphical CMake front-ends
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cca6c8fe..d418b428 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,11 @@ IF(NOT CMAKE_BUILD_TYPE)
"Choose the type of build, options are: Debug Release RelWithDebInfo MinSizeRel."
FORCE)
ENDIF()
+IF(NOT CMAKE_DEBUG_POSTFIX)
+ SET(CMAKE_DEBUG_POSTFIX "" CACHE STRING
+ "Library postfix for debug builds. Normally left blank."
+ FORCE)
+ENDIF()
IF(MSVC)
# ???