aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-10-31 04:04:49 -0700
committerChris Robinson <[email protected]>2012-10-31 04:04:49 -0700
commitf3dddb6e6342141ea7b2c9fc0790a86e6e97fc3f (patch)
tree72168402732dcee8e20da380e5ed2105d8571587 /CMakeLists.txt
parent3c3e3b123b6d3a3e220fc6db9707f449aff07010 (diff)
Add an example program showing how to apply reverb to a source
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 146bc572..bcb1fa10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -827,7 +827,14 @@ IF(EXAMPLES)
examples/alstream.c)
TARGET_LINK_LIBRARIES(alstream ${FFMPEG_LIBRARIES} ${LIBNAME})
SET_TARGET_PROPERTIES(alstream PROPERTIES COMPILE_FLAGS "${FFMPEG_CFLAGS}")
- INSTALL(TARGETS alstream
+
+ ADD_EXECUTABLE(alreverb examples/common/alhelpers.c
+ examples/common/alffmpeg.c
+ examples/alreverb.c)
+ TARGET_LINK_LIBRARIES(alreverb ${FFMPEG_LIBRARIES} ${LIBNAME})
+ SET_TARGET_PROPERTIES(alreverb PROPERTIES COMPILE_FLAGS "${FFMPEG_CFLAGS}")
+
+ INSTALL(TARGETS alstream alreverb
RUNTIME DESTINATION bin
LIBRARY DESTINATION "lib${LIB_SUFFIX}"
ARCHIVE DESTINATION "lib${LIB_SUFFIX}"