aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2013-06-23 22:47:51 -0700
committerChris Robinson <[email protected]>2013-06-23 22:47:51 -0700
commit144059b062bd357cdec27416010872f37ef69cba (patch)
treed88c0c5ef43975e5c9b61712dba5dacd25ebcab4 /CMakeLists.txt
parent4017e4a96a41ce2e781bcd99695c7f9dfc503c5f (diff)
Add a configuration UI application
Not complete, but it's a decent start. Some problems: * Only some otions are handled (backend-specific options in particular aren't handled). * Does not warn when quitting with unsaved changes. * Some options are missing tooltips.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 29 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13f8e0a2..19d1dece 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,7 @@ INCLUDE(CheckCSourceCompiles)
INCLUDE(CheckTypeSize)
-PROJECT(OpenAL C)
+PROJECT(OpenAL)
SET(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS TRUE)
@@ -865,6 +865,34 @@ IF(ALSOFT_UTILS)
ARCHIVE DESTINATION "lib${LIB_SUFFIX}"
)
MESSAGE(STATUS "Building utility programs")
+
+ find_package(Qt4)
+ if(QT_FOUND)
+ include(${QT_USE_FILE})
+ include_directories(${QT_QTCORE_INCLUDE_DIR} ${QT_QTGUI_INCLUDE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR} ${QT_QTGUI_INCLUDE_DIR})
+
+ set(alsoft-config_SRCS utils/alsoft-config/main.cpp
+ utils/alsoft-config/mainwindow.cpp
+ )
+
+ set(alsoft-config_UIS utils/alsoft-config/mainwindow.ui)
+ QT4_WRAP_UI(UIS ${alsoft-config_UIS})
+
+ set(alsoft-config_MOCS utils/alsoft-config/mainwindow.h)
+ QT4_WRAP_CPP(MOCS ${alsoft-config_MOCS})
+
+ add_executable(alsoft-config ${alsoft-config_SRCS} ${UIS} ${RSCS} ${TRS} ${MOCS})
+ target_link_libraries(alsoft-config ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
+
+ INSTALL(TARGETS alsoft-config
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION "lib${LIB_SUFFIX}"
+ ARCHIVE DESTINATION "lib${LIB_SUFFIX}"
+ )
+ message(STATUS "Building configuration program")
+ endif()
+
MESSAGE(STATUS "")
ENDIF()