aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2013-06-20 17:17:17 -0700
committerChris Robinson <[email protected]>2013-06-20 17:17:17 -0700
commit4017e4a96a41ce2e781bcd99695c7f9dfc503c5f (patch)
treef6e8f29c445fd3f4035577485446f016ef41fa26 /CMakeLists.txt
parented0568bb24ecd331bd34029d2a34bfb9f1dd3f57 (diff)
Check for MinGW in CMakeLists.txt instead of config.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4efd396c..13f8e0a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -206,7 +206,11 @@ ENDIF()
# Set visibility/export options if available
IF(WIN32)
SET(EXPORT_DECL "__declspec(dllexport)")
- SET(ALIGN_DECL "__declspec(align(x))")
+ IF(NOT MINGW)
+ SET(ALIGN_DECL "__declspec(align(x))")
+ ELSE()
+ SET(ALIGN_DECL "__declspec(aligned(x))")
+ ENDIF()
OPTION(WINE "Enable use of Wine headers when compiling" OFF)
IF(WINE)