aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2013-05-24 23:25:35 -0700
committerChris Robinson <[email protected]>2013-05-24 23:25:35 -0700
commit49446c7b3227a9b95763b0d7ee0907b1017d595b (patch)
tree67b1d723b97273f1ef86efdfda9b89084c3ce668 /CMakeLists.txt
parentf105a8bb4b29b3874b88339c6b572244bc69ba43 (diff)
Set cmake policy CMP0005 and avoid unnecessary escape sequences
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dc2e6a2..1140b053 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,7 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.4)
IF(COMMAND CMAKE_POLICY)
CMAKE_POLICY(SET CMP0003 NEW)
+ CMAKE_POLICY(SET CMP0005 NEW)
ENDIF(COMMAND CMAKE_POLICY)
SET(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
@@ -408,8 +409,8 @@ ENDIF()
CHECK_INCLUDE_FILE(stdint.h HAVE_STDINT_H)
IF(NOT HAVE_STDINT_H)
IF(HAVE_WINDOWS_H)
- CHECK_C_SOURCE_COMPILES("\#define _WIN32_WINNT 0x0501
- \#include <windows.h>
+ CHECK_C_SOURCE_COMPILES("#define _WIN32_WINNT 0x0501
+ #include <windows.h>
__int64 foo;
int main() {return 0;}" HAVE___INT64)
ENDIF()