aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-05-16 07:52:43 -0700
committerChris Robinson <[email protected]>2010-05-16 07:52:43 -0700
commit4fbb3ccf661e8f199ba48cabda48b491e2c91fec (patch)
tree0aa17f2c49ff5861e0360f3cf81b9562de7d0c84 /CMakeLists.txt
parent7f533c6a250b8963618e682e9116388338823071 (diff)
Always look for winmm under Windows
It's needed for timeGetTime, even if the WinMM backend is disabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6603c85e..47e1f8d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,6 +280,14 @@ IF(NOT HAVE_STDINT_H)
ENDIF()
ENDIF()
+IF(WIN32)
+ # Windows needs winmm for timeGetTime, even if the backend is disabled
+ CHECK_SHARED_LIBRARY_EXISTS(winmm timeGetTime 0 "" HAVE_LIBWINMM)
+ IF(HAVE_LIBWINMM)
+ SET(EXTRA_LIBS winmm ${EXTRA_LIBS})
+ ENDIF()
+ENDIF()
+
SET(OPENAL_OBJS OpenAL32/alAuxEffectSlot.c
OpenAL32/alBuffer.c