aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2014-04-19 01:10:12 -0700
committerChris Robinson <[email protected]>2014-04-19 01:10:12 -0700
commit8badd3740e1a2e13affb4553c69ca44b1649035b (patch)
treebfe084439c2cd80829a5a41007a44652c7e28c47 /CMakeLists.txt
parent1d69ec9ce16d1c85aec224a8feae80d7a5ad48ed (diff)
Dont bother trying _alloca
We prefer C99 variable-length arrays, and other systems (including MSVC9) don't have an issue with alloca.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e159bff..0d440aab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -355,12 +355,7 @@ IF(NOT HAVE_C99_VLA)
CHECK_SYMBOL_EXISTS(alloca malloc.h HAVE_ALLOCA)
ENDIF()
IF(NOT HAVE_ALLOCA)
- CHECK_SYMBOL_EXISTS(_alloca malloc.h HAVE__ALLOCA)
- IF(NOT HAVE__ALLOCA)
- MESSAGE(FATAL_ERROR "No alloca function found, please report!")
- ENDIF()
-
- ADD_DEFINITIONS(-Dalloca=_alloca)
+ MESSAGE(FATAL_ERROR "No alloca function found, please report!")
ENDIF()
ENDIF()