aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-01-15 21:23:14 -0800
committerChris Robinson <[email protected]>2008-01-15 21:23:14 -0800
commitabc69dd3d044fb5370b0a9afee05c3f2b9e79c21 (patch)
tree4eddf62618a2cc6dc88cb0d30987cdb9a64a78eb /CMakeLists.txt
parentbf87aed459a2546bcc8762dd8a849485690ffd89 (diff)
Use acosf when available
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff74f23d..056b6fdd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,7 +101,8 @@ ENDIF()
CHECK_LIBRARY_EXISTS(m sqrtf "" HAVE_SQRTF)
-IF(HAVE_SQRTF)
+CHECK_LIBRARY_EXISTS(m acosf "" HAVE_ACOSF)
+IF(HAVE_SQRTF OR HAVE_ACOSF)
SET(EXTRA_LIBS m ${EXTRA_LIBS})
ENDIF()
CHECK_FUNCTION_EXISTS(strtof HAVE_STRTOF)