aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-07-23 11:58:36 -0700
committerChris Robinson <[email protected]>2008-07-23 11:58:36 -0700
commitd45b1207d0718efab517522689ea628d34ab7d1c (patch)
tree4eeebab695558e7eaaf47cc2d07d054233ac86fe /CMakeLists.txt
parent5a9e24dea17ae2105402176cbfd3e86be4f1b35b (diff)
Make sure the correct libname is used for pkg-config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8942a0c8..2f49d3b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,12 @@ OPTION(WERROR "Treat compile warnings as errors" OFF)
OPTION(EXAMPLES "Build example programs" ON)
+IF(WIN32)
+ SET(LIBNAME openal32)
+ELSE()
+ SET(LIBNAME openal)
+ENDIF()
+
SET(LIB_MAJOR_VERSION "1")
SET(LIB_MINOR_VERSION "4")
SET(LIB_BUILD_VERSION "272")
@@ -311,12 +317,6 @@ CONFIGURE_FILE(
ADD_DEFINITIONS(-DAL_BUILD_LIBRARY)
# Build a shared library
-IF(WIN32)
- SET(LIBNAME openal32)
-ELSE()
- SET(LIBNAME openal)
-ENDIF()
-
ADD_LIBRARY(${LIBNAME} SHARED ${OPENAL_OBJS} ${ALC_OBJS})
SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES VERSION ${LIB_VERSION}
SOVERSION ${LIB_MAJOR_VERSION})