aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2007-12-20 12:32:54 -0800
committerChris Robinson <[email protected]>2007-12-20 12:32:54 -0800
commit0bef94cb483fd8a09d7be49f78474aed5a3630fe (patch)
tree99fa06dfc88bd392c9aa2c8a5fc61ab7a2b7087e /CMakeLists.txt
parent44df5c35678ae050ab072e64c09ccbe142077898 (diff)
Don't use the lib prefix for the Win32 DLL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1a49945..0dea95a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,8 +35,10 @@ SET(LIB_VERSION "${LIB_MAJOR_VERSION}.${LIB_MINOR_VERSION}.${LIB_BUILD_VERSION}"
IF("${WIN32}")
SET(LIBNAME openal32)
+ SET(TARGET_OPTS "PREFIX \"\"")
ELSE()
SET(LIBNAME openal)
+ SET(TARGET_OPTS "")
ENDIF()
@@ -256,7 +258,9 @@ ADD_DEFINITIONS(-DAL_BUILD_LIBRARY)
# Build a shared library
ADD_LIBRARY(${LIBNAME} SHARED ${OPENAL_OBJS} ${ALC_OBJS})
-SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES VERSION ${LIB_VERSION} SOVERSION ${LIB_MAJOR_VERSION})
+SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES VERSION ${LIB_VERSION}
+ SOVERSION ${LIB_MAJOR_VERSION}
+ ${TARGET_OPTS})
TARGET_LINK_LIBRARIES(${LIBNAME} ${EXTRA_LIBS})