aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-01-23 03:45:04 -0800
committerChris Robinson <[email protected]>2012-01-23 03:45:04 -0800
commit1dd8aa9b6ff21a6282c67107d6985db69809be1d (patch)
tree297503b4a2608dc39fe17699971f1d6b62656268 /CMakeLists.txt
parentf520257463635f1fb93d4885673714bde146cf36 (diff)
Link with AudioToolbox.framework for the CoreAudio backend if it's found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 752abe43..1abd4d40 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -615,6 +615,18 @@ IF(COREAUDIO)
SET(EXTRA_LIBS /System/Library/Frameworks/CoreAudio.framework ${EXTRA_LIBS})
SET(EXTRA_LIBS /System/Library/Frameworks/AudioUnit.framework ${EXTRA_LIBS})
SET(EXTRA_LIBS /System/Library/Frameworks/ApplicationServices.framework ${EXTRA_LIBS})
+
+ # Some versions of OSX may need the AudioToolbox framework. Add it if
+ # it's found.
+ FIND_LIBRARY(AUDIOTOOLBOX_LIBRARY
+ NAMES AudioToolbox
+ PATHS ~/Library/Frameworks
+ /Library/Frameworks
+ /System/Library/Frameworks
+ )
+ IF(AUDIOTOOLBOX_LIBRARY)
+ SET(EXTRA_LIBS ${AUDIOTOOLBOX_LIBRARY} ${EXTRA_LIBS})
+ ENDIF()
ENDIF()
ENDIF()
IF(REQUIRE_COREAUDIO AND NOT HAVE_COREAUDIO)