aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2009-05-19 06:35:12 -0700
committerChris Robinson <[email protected]>2009-05-19 06:35:12 -0700
commit1f5453075c20018c450d57be4bf434d14beb9dbe (patch)
treea18283b77b2fc1a187b8dd3de4b5e54cb4954d64 /CMakeLists.txt
parent33a74f159459a9e9bb6d90f26fc3b5be7814448e (diff)
Dynamically load PulseAudio
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 509b5591..780875b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -352,9 +352,12 @@ IF(PULSEAUDIO)
IF(HAVE_LIBPULSE)
SET(HAVE_PULSEAUDIO 1)
SET(ALC_OBJS ${ALC_OBJS} Alc/pulseaudio.c)
- SET(BACKENDS "${BACKENDS} PulseAudio \(linked\),")
-
- SET(EXTRA_LIBS pulse ${EXTRA_LIBS})
+ IF(HAVE_DLFCN_H)
+ SET(BACKENDS "${BACKENDS} PulseAudio,")
+ ELSE()
+ SET(BACKENDS "${BACKENDS} PulseAudio \(linked\),")
+ SET(EXTRA_LIBS pulse ${EXTRA_LIBS})
+ ENDIF()
ENDIF()
ENDIF()
ENDIF()