aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-08-16 10:33:37 -0700
committerChris Robinson <[email protected]>2012-08-16 10:33:37 -0700
commit2a8c26e390bb60e283e8371b8a79819cf26716ad (patch)
tree2f472fef736bc624f83c79d55db971bf33636a68 /CMakeLists.txt
parent3c395a82db5de3c3866dc853f43bd9c23fb02f25 (diff)
Remove extra parenthesis used in the aligned attribute declaration
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92bc4e42..5f08d736 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -174,7 +174,7 @@ ENDIF()
# Set visibility/export options if available
IF(WIN32)
SET(EXPORT_DECL "__declspec(dllexport)")
- SET(ALIGN_DECL "__declspec(align((x)))")
+ SET(ALIGN_DECL "__declspec(align(x))")
OPTION(WINE "Enable use of Wine headers when compiling" OFF)
IF(WINE)
@@ -223,7 +223,7 @@ ELSE()
CHECK_C_SOURCE_COMPILES("int foo __attribute__((aligned(16)));
int main() {return 0;}" HAVE_ATTRIBUTE_ALIGNED)
IF(HAVE_ATTRIBUTE_ALIGNED)
- SET(ALIGN_DECL "__attribute__((aligned((x))))")
+ SET(ALIGN_DECL "__attribute__((aligned(x)))")
ENDIF()
SET(CMAKE_REQUIRED_FLAGS "${OLD_REQUIRED_FLAGS}")