aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-10-31 22:39:57 -0700
committerChris Robinson <[email protected]>2012-10-31 23:53:10 -0700
commit41b1ba146a3742f70f9a0a6b7de3e5811d95d16c (patch)
tree9474d11fd87448f47d1703c2361dd5e877aa1c38 /CMakeLists.txt
parent6450d0cbcad5afb314af8b26bdfc634d22158687 (diff)
Add an example to get and show the source latency
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcb1fa10..d793eed6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -834,7 +834,13 @@ IF(EXAMPLES)
TARGET_LINK_LIBRARIES(alreverb ${FFMPEG_LIBRARIES} ${LIBNAME})
SET_TARGET_PROPERTIES(alreverb PROPERTIES COMPILE_FLAGS "${FFMPEG_CFLAGS}")
- INSTALL(TARGETS alstream alreverb
+ ADD_EXECUTABLE(allatency examples/common/alhelpers.c
+ examples/common/alffmpeg.c
+ examples/allatency.c)
+ TARGET_LINK_LIBRARIES(allatency ${FFMPEG_LIBRARIES} ${LIBNAME})
+ SET_TARGET_PROPERTIES(allatency PROPERTIES COMPILE_FLAGS "${FFMPEG_CFLAGS}")
+
+ INSTALL(TARGETS alstream alreverb allatency
RUNTIME DESTINATION bin
LIBRARY DESTINATION "lib${LIB_SUFFIX}"
ARCHIVE DESTINATION "lib${LIB_SUFFIX}"