aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2011-05-01 13:59:44 -0700
committerChris Robinson <[email protected]>2011-05-01 13:59:44 -0700
commit56d9418119045d536efa3f552af6e13d9353ada9 (patch)
treea1688ab2434cd8f3c1bfdb2c928117b50c357b08 /CMakeLists.txt
parent0109104027ec4de46c236f6520cf00d89dd980ad (diff)
Add an HRTF filter for mono sources
The data is based on the KEMAR HRTF data provided by MIT, which can be found at <http://sound.media.mit.edu/resources/KEMAR.html>. The compact measurements were used. See hrtf_tables.inc for more information. The filter is only available for stereo output, using a 44100hz playback rate. Note also that it currently only applies to mono sounds, and the cf_level and head_dampen config options are ignored while it is active.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5631a3f7..78110594 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -327,6 +327,7 @@ SET(ALC_OBJS Alc/ALc.c
Alc/alcRing.c
Alc/alcThread.c
Alc/bs2b.c
+ Alc/hrtf.c
Alc/mixer.c
Alc/panning.c
Alc/loopback.c