aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2009-05-17 22:36:45 -0700
committerChris Robinson <[email protected]>2009-05-17 22:36:45 -0700
commite4da1224cbfd85bad56863d5a512fd197cc3a09b (patch)
tree0e96ce45447ae7588045c5fcd3fae693eeb02c8d /CMakeLists.txt
parent5c2a47620c73df0f7dcfbdadef15ae1beded4288 (diff)
Optionally install the sample configuration file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 749e0122..509b5591 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,8 @@ OPTION(WERROR "Treat compile warnings as errors" OFF)
OPTION(EXAMPLES "Build example programs" ON)
+OPTION(ALSOFT_CONFIG "Install alsoft.conf configuration file" OFF)
+
IF(WIN32)
SET(LIBNAME OpenAL32)
@@ -406,6 +408,14 @@ INSTALL(FILES include/AL/al.h
INSTALL(FILES "${OpenAL_BINARY_DIR}/admin/pkgconfig/openal.pc"
DESTINATION "${LIB_INSTALL_DIR}/pkgconfig")
+# Install alsoft.conf configuration file
+IF(ALSOFT_CONFIG)
+ INSTALL(FILES alsoftrc.sample
+ DESTINATION /etc/openal
+ RENAME alsoft.conf
+ )
+ENDIF()
+
IF(EXAMPLES)
ADD_EXECUTABLE(openal-info examples/openal-info.c)
TARGET_LINK_LIBRARIES(openal-info ${LIBNAME})