aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2017-07-07 18:35:56 -0700
committerChris Robinson <[email protected]>2017-07-07 18:41:03 -0700
commite4e240fa9bcd85a9f5033f559ba15ca2d763de4c (patch)
treef09223cad7e99d163328b60ebb81a2b92834663d /CMakeLists.txt
parent6be752a9b1a38379b8631c5dcb6c47e099af4f02 (diff)
Support ALC_EXT_thread_local_context in the router
Note that a given context's device must also support the extension to work. The router's support simply lets a driver's capabilities through.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f596db4b..ffc9fd9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1288,6 +1288,7 @@ if(WIN32 AND ALSOFT_BUILD_ROUTER)
ADD_LIBRARY(Router SHARED router/router.c router/alc.c router/al.c ${COMMON_OBJS})
SET_PROPERTY(TARGET Router APPEND PROPERTY COMPILE_FLAGS ${EXTRA_CFLAGS})
+ SET_PROPERTY(TARGET Router APPEND PROPERTY COMPILE_DEFINITIONS AL_BUILD_LIBRARY AL_ALEXT_PROTOTYPES)
SET_PROPERTY(TARGET OpenAL APPEND_STRING PROPERTY LINK_FLAGS ${EXTRA_LDFLAGS})
IF(MSVC)
SET_PROPERTY(TARGET Router APPEND_STRING PROPERTY LINK_FLAGS " /SUBSYSTEM:WINDOWS")