aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-01-12 08:48:25 -0800
committerChris Robinson <[email protected]>2010-01-12 08:48:25 -0800
commit0c2efa1253514dbaeb15cc72a704761ed598c4fc (patch)
treeacdf975f01646a1fcb6aac6aaa0798ce0f9b1014 /CMakeLists.txt
parent5921e18be29d04a1164c69be36289bf703418e11 (diff)
Use GCC's format attribute for al_printf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c60a11e..1577e054 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,9 @@ ELSE()
ENDIF()
ENDIF()
+CHECK_C_SOURCE_COMPILES("int foo(const char *str, ...) __attribute__((format(printf, 1, 2)));
+ int main() {return 0;}" HAVE_GCC_FORMAT)
+
CHECK_INCLUDE_FILE(fenv.h HAVE_FENV_H)
CHECK_INCLUDE_FILE(float.h HAVE_FLOAT_H)