aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2018-01-16 19:24:14 -0800
committerChris Robinson <[email protected]>2018-01-16 19:28:10 -0800
commit3baf9d0e81c16555fc417697a5445b7cd674db02 (patch)
tree3586c9a938ada32394cdc05430332f01da7e6728 /CMakeLists.txt
parent248832b26680de4ce48bf17076287a07dbd36ff7 (diff)
Add a method to get the system's page size
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b07f4ea..dd371f70 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -499,6 +499,7 @@ IF(HAVE_INTRIN_H)
}" HAVE_CPUID_INTRINSIC)
ENDIF()
+CHECK_SYMBOL_EXISTS(sysconf unistd.h HAVE_SYSCONF)
CHECK_SYMBOL_EXISTS(aligned_alloc stdlib.h HAVE_ALIGNED_ALLOC)
CHECK_SYMBOL_EXISTS(posix_memalign stdlib.h HAVE_POSIX_MEMALIGN)
CHECK_SYMBOL_EXISTS(_aligned_malloc malloc.h HAVE__ALIGNED_MALLOC)