aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2017-12-16 15:01:05 -0800
committerChris Robinson <[email protected]>2017-12-16 15:01:05 -0800
commit6fe6c370c2101bc2a7d48c5a0965ee3e6f132822 (patch)
tree7c0bd7a76f22d392569e0e367e5599ed21718605 /CMakeLists.txt
parent42acafcbc3e5932dd653d2f1e46841f3d0902c68 (diff)
Include the fpu=neon switch when testing for arm_neon.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 965a701e..8a7744e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -844,7 +844,7 @@ ENDIF()
# Check for ARM Neon support
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
-CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H)
+CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H ${FPU_NEON_SWITCH})
IF(HAVE_ARM_NEON_H)
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
IF(ALSOFT_CPUEXT_NEON)