aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2018-01-21 23:50:47 -0800
committerChris Robinson <[email protected]>2018-01-21 23:50:47 -0800
commitca07e210a7790272718305529a3e2e5ee0ea6df2 (patch)
treee9dfe41907c3897a1444d93a1a93835c50026a3b /CMakeLists.txt
parent5f3ae527c92fa1fda0ea87be9629db2c320831ec (diff)
Remove now-unused alloca and VLA checks
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd371f70..76aa19b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,16 +228,6 @@ IF(HAVE_LIBLOG)
SET(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} log)
ENDIF()
-# Check if we have C99 variable length arrays
-CHECK_C_SOURCE_COMPILES(
-"int main(int argc, char *argv[])
- {
- volatile int tmp[argc];
- tmp[0] = argv[0][0];
- return tmp[0];
- }"
-HAVE_C99_VLA)
-
# Check if we have C99 bool
CHECK_C_SOURCE_COMPILES(
"int main(int argc, char *argv[])
@@ -506,12 +496,6 @@ CHECK_SYMBOL_EXISTS(_aligned_malloc malloc.h HAVE__ALIGNED_MALLOC)
CHECK_SYMBOL_EXISTS(lrintf math.h HAVE_LRINTF)
CHECK_SYMBOL_EXISTS(modff math.h HAVE_MODFF)
CHECK_SYMBOL_EXISTS(log2f math.h HAVE_LOG2F)
-IF(NOT HAVE_C99_VLA)
- CHECK_SYMBOL_EXISTS(alloca malloc.h HAVE_ALLOCA)
- IF(NOT HAVE_ALLOCA)
- MESSAGE(FATAL_ERROR "No alloca function found, please report!")
- ENDIF()
-ENDIF()
IF(HAVE_FLOAT_H)
CHECK_SYMBOL_EXISTS(_controlfp float.h HAVE__CONTROLFP)