aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2017-06-23 05:19:24 -0700
committerChris Robinson <[email protected]>2017-06-23 05:19:24 -0700
commite07166e93cf392e3dac0a8ee71696a8d6d5114fc (patch)
tree628ed0885ff0f01fb181617293f2daec6303dced /CMakeLists.txt
parentd1077795deb8367d8e6fc39ecfc5f51b3c39d9e5 (diff)
Add a recording example app
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6fcdb964..f8f10fe3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1409,6 +1409,20 @@ IF(ALSOFT_TESTS)
ENDIF()
IF(ALSOFT_EXAMPLES)
+ ADD_EXECUTABLE(alrecord examples/alrecord.c ${COMMON_OBJS})
+ TARGET_LINK_LIBRARIES(alrecord OpenAL)
+ SET_PROPERTY(TARGET alrecord APPEND PROPERTY COMPILE_FLAGS ${EXTRA_CFLAGS})
+
+ IF(ALSOFT_INSTALL)
+ INSTALL(TARGETS alrecord
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
+ ENDIF()
+
+ MESSAGE(STATUS "Building example programs")
+
IF(SDL2_FOUND)
IF(SDL_SOUND_FOUND)
SET(EX_COMMON_OBJS examples/common/alhelpers.c)