aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-12-07 02:20:17 -0800
committerChris Robinson <[email protected]>2008-12-07 02:20:17 -0800
commited03570e1afc8547069216ed7952cd779da7b20b (patch)
tree866b90419e737ba6a37125055358e03a8b6cfa2a /CMakeLists.txt
parent2ec0e48d064d5a98b543ab3844e0114f1c17b1ce (diff)
Fix some CMake checks
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 415b8839..0a87221d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,7 +82,7 @@ IF(MSVC)
ELSE()
ADD_DEFINITIONS(-Wall)
CHECK_C_COMPILER_FLAG(-Wextra HAVE_W_EXTRA)
- IF("${HAVE_W_EXTRA}")
+ IF(HAVE_W_EXTRA)
ADD_DEFINITIONS(-Wextra)
ENDIF()
@@ -109,10 +109,10 @@ ELSE()
int main() {return 0;}" HAVE_GCC_DESTRUCTOR)
CHECK_C_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_SWITCH)
- IF("${HAVE_VISIBILITY_SWITCH}")
+ IF(HAVE_VISIBILITY_SWITCH)
CHECK_C_SOURCE_COMPILES("int foo() __attribute__((visibility(\"default\")));
int main() {return 0;}" HAVE_GCC_VISIBILITY)
- IF("${HAVE_GCC_VISIBILITY}")
+ IF(HAVE_GCC_VISIBILITY)
ADD_DEFINITIONS(-fvisibility=hidden -DHAVE_GCC_VISIBILITY)
ENDIF()
ENDIF()