aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-03-22 23:09:04 -0700
committerChris Robinson <[email protected]>2010-03-22 23:09:04 -0700
commitef92c6345597a2ebf0a47cae6e0bb7b38497e213 (patch)
tree6f944e33768d91c44019baebcac88d87efa5d426 /CMakeLists.txt
parentae8858c5168c9076ae834ba0cebe127b7daf57b9 (diff)
Define AL_BUILD_LIBRARY only when building the lib
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02b8aa58..decc2542 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -437,14 +437,13 @@ CONFIGURE_FILE(
"${OpenAL_BINARY_DIR}/openal.pc"
@ONLY)
-ADD_DEFINITIONS(-DAL_BUILD_LIBRARY)
-
# Build a library
IF(NOT LIBTYPE)
SET(LIBTYPE SHARED)
ENDIF()
ADD_LIBRARY(${LIBNAME} ${LIBTYPE} ${OPENAL_OBJS} ${ALC_OBJS})
-SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES VERSION ${LIB_VERSION}
+SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES DEFINE_SYMBOL AL_BUILD_LIBRARY
+ VERSION ${LIB_VERSION}
SOVERSION ${LIB_MAJOR_VERSION})
IF(WIN32)
SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES PREFIX "")