aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2017-03-04 20:25:10 -0800
committerChris Robinson <[email protected]>2017-03-04 22:30:57 -0800
commit87fd28835953bf5bb2a84f061675bddbcc5bf40d (patch)
tree69f048f642e6097ba7ca1b8b14a5faa02fa70e96 /CMakeLists.txt
parentc013068003a6ccd63e335fe94f43caf1b769ff7e (diff)
Remove unnecessary wrappers around SDL_sound
Also remove wrappers for the now-unsupported buffer_samples extension.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b5a8553..8f279951 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1464,12 +1464,8 @@ ENDIF()
IF(ALSOFT_EXAMPLES)
IF(SDL2_FOUND)
IF(SDL_SOUND_FOUND)
- ADD_LIBRARY(ex-common STATIC examples/common/alhelpers.c
- examples/common/sdl_sound.c)
+ ADD_LIBRARY(ex-common STATIC examples/common/alhelpers.c)
SET_PROPERTY(TARGET ex-common APPEND PROPERTY COMPILE_FLAGS ${EXTRA_CFLAGS})
- SET_PROPERTY(TARGET ex-common APPEND PROPERTY
- INCLUDE_DIRECTORIES ${SDL2_INCLUDE_DIR} ${SDL_SOUND_INCLUDE_DIR}
- )
ADD_EXECUTABLE(alstream examples/alstream.c ${COMMON_OBJS})
TARGET_LINK_LIBRARIES(alstream ex-common ${SDL_SOUND_LIBRARIES} ${SDL2_LIBRARY}