aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2015-11-10 18:40:11 -0800
committerChris Robinson <[email protected]>2015-11-10 18:40:11 -0800
commita37cda0214b7dc973915aba8f5a02ba4eb6f3d44 (patch)
tree16aaf7cc8de59390951081366e67a80ecce7525b /CMakeLists.txt
parent10bcda27a92c7ec1c78a31111097d3cec127f5b2 (diff)
Add a tool to generate the bsinc tables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7bbe691..ee7fa67a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1173,8 +1173,13 @@ IF(ALSOFT_UTILS)
TARGET_LINK_LIBRARIES(makehrtf m)
ENDIF()
+ ADD_EXECUTABLE(bsincgen utils/bsincgen.c)
+ IF(HAVE_LIBM)
+ TARGET_LINK_LIBRARIES(bsincgen m)
+ ENDIF()
+
IF(ALSOFT_INSTALL)
- INSTALL(TARGETS openal-info makehrtf
+ INSTALL(TARGETS openal-info makehrtf bsincgen
RUNTIME DESTINATION bin
LIBRARY DESTINATION "lib${LIB_SUFFIX}"
ARCHIVE DESTINATION "lib${LIB_SUFFIX}"