aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-08-16 10:12:50 -0700
committerChris Robinson <[email protected]>2012-08-16 10:12:50 -0700
commit147fd9de4eeba24fc6e80d78cf9beedf51b0d6d9 (patch)
tree2e1b1eaeef4a4a3bf1feb0d7ef5b2dbc617c19d8 /CMakeLists.txt
parent0bca771a88f83e77cd6a5eb04757125b4fa5dc6c (diff)
Avoid dynamic handling of libsndio
This makes it safer and easier to handle as OpenBSD updates it
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8ecfd8f..0634e4eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -560,15 +560,11 @@ IF(SNDIO)
CHECK_INCLUDE_FILE(sndio.h HAVE_SNDIO_H)
IF(HAVE_SNDIO_H)
CHECK_SHARED_FUNCTION_EXISTS(sio_open "sndio.h" sndio "" HAVE_LIBSNDIO)
- IF(HAVE_LIBSNDIO OR HAVE_DLFCN_H OR WIN32)
+ IF(HAVE_LIBSNDIO)
SET(HAVE_SNDIO 1)
SET(ALC_OBJS ${ALC_OBJS} Alc/backends/sndio.c)
- IF(HAVE_DLFCN_H OR WIN32)
- SET(BACKENDS "${BACKENDS} SndIO,")
- ELSE()
- SET(BACKENDS "${BACKENDS} SndIO \(linked\),")
- SET(EXTRA_LIBS sndio ${EXTRA_LIBS})
- ENDIF()
+ SET(BACKENDS "${BACKENDS} SndIO \(linked\),")
+ SET(EXTRA_LIBS sndio ${EXTRA_LIBS})
ENDIF()
ENDIF()
ENDIF()