aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkcat <[email protected]>2015-12-20 03:26:20 -0800
committerkcat <[email protected]>2015-12-20 03:26:20 -0800
commit1930ee3e5fee3c2f3bc4fa2386e9382a7cd6d600 (patch)
tree2f6414d9a85cdb3222b1c64cf44bd852939a85b1 /CMakeLists.txt
parent3dc5f0bf7658d7758abbf633070e8f1c59b0faf0 (diff)
parentd93398a361da94cbb4f0ab07046fbab7c5e94e5d (diff)
Merge pull request #29 from olesalscheider/master
Allow to override the share install dir
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fb0632b..d6ffe9a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,9 @@ OPTION(ALSOFT_HRTF_DEFS "Install HRTF definition files" ON)
OPTION(ALSOFT_INSTALL "Install headers and libraries" ON)
+set(SHARE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "The share install dir")
+
+
IF(NOT WIN32)
SET(LIBNAME openal)
ELSE()
@@ -1174,7 +1177,7 @@ ENDIF()
# Install alsoft.conf configuration file
IF(ALSOFT_CONFIG)
INSTALL(FILES alsoftrc.sample
- DESTINATION share/openal
+ DESTINATION ${SHARE_INSTALL_DIR}/openal
)
MESSAGE(STATUS "Installing sample configuration")
MESSAGE(STATUS "")
@@ -1184,7 +1187,7 @@ ENDIF()
IF(ALSOFT_HRTF_DEFS)
INSTALL(FILES hrtf/default-44100.mhr
hrtf/default-48000.mhr
- DESTINATION share/openal/hrtf
+ DESTINATION ${SHARE_INSTALL_DIR}/openal/hrtf
)
MESSAGE(STATUS "Installing HRTF definitions")
MESSAGE(STATUS "")