aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2014-09-05 17:47:32 -0700
committerChris Robinson <[email protected]>2014-09-05 17:47:32 -0700
commit4d19d4f416f39902f5bb08e822c262d571136aa6 (patch)
tree9c22c024bfe534ab256ba9bbd193c0d9a68f0eab /CMakeLists.txt
parentab829fd90636f9e5d8216424365136bb14613bdf (diff)
Check that atomic_load works with a const _Atomic
The original C11 spec does not allow atomic_load to work on const _Atomic variables, which we sometimes do in alGet* methods, despite the fact that it does not modify the variable. An update to the C spec corrects this oversight, and GCC 4.9 has allowed it anyway, while Clang 3.4 does not.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a66ea70a..c4d4286c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,7 +186,7 @@ HAVE_C11_ALIGNAS)
# Check if we have C11 _Atomic
CHECK_C_SOURCE_COMPILES(
"#include <stdatomic.h>
- int _Atomic foo;
+ const int _Atomic foo = ATOMIC_VAR_INIT(~0);
int main()
{
return atomic_load(&foo);