aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2011-03-11 00:13:44 -0800
committerChris Robinson <[email protected]>2011-03-11 00:13:44 -0800
commit031a2a1b1e37a198c64f49ac8994d4c589dabcf9 (patch)
tree05e8a4d62e6843f9f4135db7bb95b574c0f314d1 /CMakeLists.txt
parent9c87b73ad576f1c2abf22cfd38eb055eef34c67f (diff)
Implement a basic non-real-time loopback device
Currently it behaves just like a normal device except contexts are only processed during calls to alcRenderSamples. Additionally, the ALC_SYNC and ALC_REFRESH context attributes are not valid for these devices, and there are two new context attributes to specify the rendering format: ALC_FORMAT_TYPE and ALC_FORMAT_CHANNELS. These each take one of the type and channel enums added. This stuff is subject to change.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44f9ea84..2cd7aafa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -327,6 +327,7 @@ SET(ALC_OBJS Alc/ALc.c
Alc/bs2b.c
Alc/mixer.c
Alc/panning.c
+ Alc/loopback.c
Alc/null.c
)