aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2018-11-26 23:45:04 -0800
committerChris Robinson <[email protected]>2018-11-26 23:45:04 -0800
commit2530370ff29009fccad472c9e9194ebdd561a398 (patch)
treea3a41655bb1b2c37a91d10f77f112d36d726af0d /CMakeLists.txt
parentd7d99adc915583416dd8c70491ec7fc4ac71a543 (diff)
Avoid relying on struct timespec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26476a67..c9f2e336 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,13 +204,6 @@ IF(CMAKE_COMPILER_IS_GNUCC)
SET(CMAKE_REQUIRED_FLAGS "${OLD_REQUIRED_FLAGS}")
ENDIF()
-# Check if we have a proper timespec declaration
-CHECK_STRUCT_HAS_MEMBER("struct timespec" tv_sec time.h HAVE_STRUCT_TIMESPEC)
-IF(HAVE_STRUCT_TIMESPEC)
- # Define it here so we don't have to include config.h for it
- SET(CPP_DEFS ${CPP_DEFS} HAVE_STRUCT_TIMESPEC)
-ENDIF()
-
# Some systems may need libatomic for C11 atomic functions to work
SET(OLD_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES})
SET(CMAKE_REQUIRED_LIBRARIES ${OLD_REQUIRED_LIBRARIES} atomic)