aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-01-02 11:52:20 -0800
committerChris Robinson <[email protected]>2012-01-02 11:52:20 -0800
commit5b7f8c1816544102011815ee570093c3ae7d339e (patch)
tree768d79b35cfa8e76c7ef97020389d5b7c941aafb /CMakeLists.txt
parent18216ab1a9a2369df6b901db81f42411da8a59b2 (diff)
Check earlier for ffmpeg
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e0f9dae..d98010aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -648,6 +648,10 @@ ENDIF()
# This is always available
SET(BACKENDS "${BACKENDS} Null")
+IF(EXAMPLES)
+ PKG_CHECK_MODULES(FFMPEG libavcodec libavformat)
+ENDIF()
+
IF(LIBTYPE STREQUAL "STATIC")
ADD_DEFINITIONS(-DAL_LIBTYPE_STATIC)
SET(PKG_CONFIG_CFLAGS -DAL_LIBTYPE_STATIC ${PKG_CONFIG_CFLAGS})
@@ -735,7 +739,6 @@ IF(UTILS)
ENDIF()
IF(EXAMPLES)
- PKG_CHECK_MODULES(FFMPEG libavcodec libavformat)
IF(FFMPEG_FOUND)
ADD_EXECUTABLE(alstream examples/alhelpers.c examples/alffmpeg.c examples/alstream.c)
TARGET_LINK_LIBRARIES(alstream ${FFMPEG_LIBRARIES} ${LIBNAME})