aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2011-09-20 18:35:27 -0700
committerChris Robinson <[email protected]>2011-09-20 18:35:27 -0700
commit64080250ffbdfbdfef47f2f9ede8a8c3a8e4a984 (patch)
treeaece38d15f9b543732cdaacf9f7d566028775ade /CMakeLists.txt
parent4e19f82a2b5cd53d0efec226b319b825fa280f4c (diff)
Actually check for hidden visibility
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b52e469c..2d2f7658 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,7 +199,7 @@ ELSE()
IF(HAVE_VISIBILITY_INTERNAL_SWITCH)
ADD_DEFINITIONS(-fvisibility=internal)
ELSE()
- CHECK_C_COMPILER_FLAG(-fvisibility=internal HAVE_VISIBILITY_HIDDEN_SWITCH)
+ CHECK_C_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN_SWITCH)
IF(HAVE_VISIBILITY_HIDDEN_SWITCH)
ADD_DEFINITIONS(-fvisibility=hidden)
ENDIF()