aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-05-28 16:41:52 -0700
committerChris Robinson <[email protected]>2010-05-28 16:41:52 -0700
commit880902feccccad61ceb8541b6571ae42a3e56d9a (patch)
tree7a7594e75f64938656d3d4bcbab5c62781a74183 /CMakeLists.txt
parent96cf5b728269915e24fdfde09eb4b9e3091a0980 (diff)
Add a Null Output device
This device will mix and fully process contexts as normal
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36c192e6..fe7bdb48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -310,6 +310,7 @@ SET(ALC_OBJS Alc/ALc.c
Alc/alcRing.c
Alc/alcThread.c
Alc/bs2b.c
+ Alc/null.c
Alc/wave.c
)
@@ -424,7 +425,7 @@ IF(PULSEAUDIO)
ENDIF()
# This is always available
-SET(BACKENDS "${BACKENDS} WaveFile")
+SET(BACKENDS "${BACKENDS} WaveFile, Null")
# Needed for openal.pc.in
SET(prefix ${CMAKE_INSTALL_PREFIX})