aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2011-07-13 01:49:43 -0700
committerChris Robinson <[email protected]>2011-07-13 01:49:43 -0700
commit99bcb7a0f6ccce2fe673016f702a85b62bfb6805 (patch)
tree868bde55a055d40e4a14fa2f94f32e1058bd704f /CMakeLists.txt
parent17773c56449475c1d255d839b89400668f15f40f (diff)
Use both root paths when looking for Wine headers, and disable them by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f105237f..97d9b6e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -166,12 +166,13 @@ ENDIF()
IF(WIN32)
SET(EXPORT_DECL "__declspec(dllexport)")
- OPTION(WINE "Enable use of Wine headers when compiling" ON)
+ OPTION(WINE "Enable use of Wine headers when compiling" OFF)
IF(WINE)
FIND_PATH(WINE_INCLUDE_DIR library.h
PATHS
/usr/include/wine
- /usr/local/include/wine)
+ /usr/local/include/wine
+ CMAKE_FIND_ROOT_PATH_BOTH)
IF(WINE_INCLUDE_DIR)
MESSAGE(STATUS "Found Wine header files - ${WINE_INCLUDE_DIR}" )
INCLUDE_DIRECTORIES("${WINE_INCLUDE_DIR}/windows")